Twoje PC  
Zarejestruj się na Twoje PC
TwojePC.pl | PC | Komputery, nowe technologie, recenzje, testy
B O A R D
   » Board
 » Zadaj pytanie
 » Archiwum
 » Szukaj
 » Stylizacja

 
M E N U
  0
 » Nowo¶ci
0
 » Archiwum
0
 » Recenzje / Testy
0
 » Board
0
 » Rejestracja
0
0
 
Szukaj @ TwojePC
 

w Newsach i na Boardzie
 
OBECNI NA TPC
 
 » Master/Pe 20:38
 » petropank 20:37
 » rurecznik 20:37
 » JaroMi 20:36
 » tog 20:36
 » MacLeod 20:36
 » Gab 20:35
 » RusH 20:32
 » Venom79 20:32
 » teneo 20:31
 » GULIwer 20:31
 » lol555 20:30
 » Liu CAs 20:30
 » Adex1234 20:30
 » Zbyszek.J 20:30
 » rooter666 20:28
 » wrrr 20:26
 » past 20:26
 » Dhoine 20:25
 » Dexter 20:24

 Dzisiaj przeczytano
 60357 postów,
 wczoraj 63121

 Szybkie ładowanie
 jest:
wył±czone.

 
TwojePC.pl © 2001 - 2019
A R C H I W A L N A   W I A D O M O ¦ Ć
    

[Excel] Data wykonania, termin realizacji - formuła ile dni po terminie , Sith 2/11/11 11:46
Witam,

mam straszny problem - mam arkusz excela w którym zapisuję sobie rzeczy oddane mi do naprawy. Przykładowo rower - data przyjęcia - dni na realizację.
Jak ustawić formułę żeby mi pokazywał ile dni jest po terminie?

Przeszukałem net, próbowałem wielu możliwo¶ci ale nie działa...

pomocy!:)

  1. wrzucasz , Matti 2/11/11 12:02
    =DZI¦()-A1+B1, gdzie A1 to data przyjęcia a B1 liczba dni na realizację.

    1. poprawka , Matti 2/11/11 12:05
      =DZI¦()-(A1+B1)

  2. spróbuj tak , PaszkfiL 2/11/11 12:07
    =JEŻELI(A1>0;ZŁˇCZ.TEKSTY(A1;" po terminie");ZŁˇCZ.TEKSTY(A1*-1;" przed terminem"))

    o([-_-])o ..::Love::BaSS::..

  3. Mozna w ten sposób: , khobar 2/11/11 12:09
    Zakładaj±c że w kolumnie B masz datę przyjęcia, w C ilo¶c dni na realizację :
    =IF(DAYS360(B2+C2;NOW())>0;DAYS360(B2+C2;NOW());"-")

    Funkcja DAYS360 liczy róznicę dni od daty przyjęcia + ilo¶c dni. Jeżeli warto¶c tego wyjdzie dodatnia to wtedy pokaze sie numer, jezeli ujemna to tylko -

    (Office 2007 wersja eng , czyli zamień IF na JEŻELI nie wiem jak z funkcj± DAYS365 zobacz w funkcjach daty)

    Zapraszam http://khobar.ovh.org

  4. s.w. , Bergerac 2/11/11 12:26
    ...

    Barbossa: You're supposed to be dead!
    Jack Sparrow: Am I not?

  5. załóżmy , Chrisu 2/11/11 12:44
    że a1 - data oddania w formacie rrr-mm-dd, a2 - ile dni na realizacę, to w a3 będzie:
    =JEŻELI(DATA.RÓŻNICA(A1;DZI¦();"D")<B1;"przed terminem";"po terminie")

    /// GG# 1 110 10 10 11 100 10 \\\

    1. aha, chcesz wiedzieć ile po terminie... to tak: , Chrisu 2/11/11 12:48
      =JEŻELI(DATA.RÓŻNICA(A1;DZI¦();"D")<B1;"przed terminem";"po terminie "&(DATA.RÓŻNICA(A1;DZI¦();"D")-B1)&" dni ")

      /// GG# 1 110 10 10 11 100 10 \\\

      1. hehe , Matti 2/11/11 13:52
        tylko po co tak skomplikowanie? Chyba, że robisz na ocenę ;)

        1. no tak ;) , Chrisu 2/11/11 14:05
          on chce wiedzieć tylko ile po terminie... Nie że już po i ile..

          /// GG# 1 110 10 10 11 100 10 \\\

  6. ... , Sith 3/11/11 06:09
    dziękuję wszystkim za pomoc! Udało się:)

    Użyłem funkcji:
    =JEŻELI(DNI.360(D6+O6;DZI¦())>0;DNI.360(D6+O6;DZI¦());"-")

    + formatowanie warunkowe:)

  7. Jeszcze jedno pytanie, głównie do khobar , Sith 3/11/11 07:32
    Mam Twoj± funkcję -
    =JEŻELI(DNI.360(D6+O6;DZI¦())>0;DNI.360(D6+O6;DZI¦());"-")

    I teraz nawet jak co¶ jest wyzerowane to mi liczy dni po terminie + funkcja warunkowa z kolorem.
    Chciałbym gdy co¶ jest wyzerowane pokazywało '-'. Tj. Gdy komórka X ma warto¶ć zero by pokazywało "-".

    Jest taka możliwo¶ć?

    Lub już trudniej, gdyby komórka X miała warto¶ć 0, by odliczanie się pokazywało.
    Przykładowo - za pół roku patrzę na dane zlecenie i widzę, że zostało to wykonane X dni po terminie.

    1. Można... , khobar 3/11/11 12:08
      ..dodać kolumnę Zrealizowano ( np niech to będzie D)
      I dodajemy warunek JEŻELI sprawdzaj±cy czy komórka D2 jest pusta. Aby było jeszcze ładniej to dodajemy kolejny warunek który doda tekst po realizacji. Formatowanie warunkowe niech szuka wyrazu "Zrealizowano" lub zamiast dodawania tekstu można zrobić aby niezrealizowane były jako ujemne a zrealizowane dodatnie . Funkcja powinna wtedy wygladać tak :

      =JEŻELI(ORAZ(DNI.360(B2+C2;DZI¦())>0;D2="");DNI.360(B2+C2;DZI¦());JEŻELI(D2="";"-";"Zrealizowano po " & D2-B2&" dniach"))

      Zapraszam http://khobar.ovh.org

    
All rights reserved ® Copyright and Design 2001-2019, TwojePC.PL