Twoje PC  
Zarejestruj się na Twoje PC
TwojePC.pl | PC | Komputery, nowe technologie, recenzje, testy
B O A R D
   » Board
 » Zadaj pytanie
 » Archiwum
 » Szukaj
 » Stylizacja

 
M E N U
  0
 » Nowości
0
 » Archiwum
0
 » Recenzje / Testy
0
 » Board
0
 » Rejestracja
0
0
 
Szukaj @ TwojePC
 

w Newsach i na Boardzie
 
OBECNI NA TPC
 
 » vasart 20:03
 » Ramen 20:03
 » Fight 20:02
 » metacom 20:01
 » cVas 20:01
 » DJopek 20:00
 » myszon 19:59
 » MacLeod 19:59
 » McMi21 19:58
 » Wyrzym 19:57
 » piotrszac 19:57
 » Artaa 19:55
 » Conan Bar 19:55
 » abes99 19:54
 » Kalkin 19:54
 » Raffi 19:51
 » milekp 19:51
 » OBoloG 19:50
 » jah 19:47
 » past 19:47

 Dzisiaj przeczytano
 44642 postów,
 wczoraj 57313

 Szybkie ładowanie
 jest:
wyłączone.

 
TwojePC.pl © 2001 - 2019
A R C H I W A L N A   W I A D O M O Ś Ć
    

Wiedźmin 2 linux mint - ponownie , Blum 1/02/15 14:44
Witam. Po nieudanych próbach z odpaleniem Wiedźmina 2 na linuxie przez Wine, zaciągnąłem z GOGa wersję na Linuxa. Niestety - porażka. Po zainstalowaniu, odpalenie launchera powoduje wyświetlenie panelu startowego - po kliknięciu "uruchom grę" panel znika i nic się nie dzieje...

Co zrobić?

(Linux Mint 64b, mate)

  1. diagnozować :) , ptoki 1/02/15 15:56
    Ja bym zaczął od uruchomienia z konsoli tego co tam klikasz.
    Wtedy po przeklikaniu i wywałce jest szansa na zobaczenie na co narzeka ten launcher.

    Zerknij tez w logi systemowe, tam moga byc jakieś wskazówki.

    I na poczatek sprawdz czy sprzet i sterowniki są wspierane przez gre.

    Na deser sprawdz selinuxa bo moze jakiś przypadek ktoś włączył :)

    1. odpalone z konsoli daje taki komunikat , Blum 1/02/15 18:24
      : error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

      1. muszisz sobie doinstalować bibioteke , ptoki 1/02/15 18:47
        o jakiej jest mowa.
        nie wiem jak to w mincie jest ale zazwyczaj jej nazwa to libSDL albo SDL costam.
        zerknij do managera pakietów i zobacz co tam bedzie oferował po frazie "SDL".

        Nie instaluj żadnych pakietów z przyrostkiem devel. Nie beda ci potrzebne.

        Doinstaluj i ponów uruchomienie. Zazwyczaj trzeba po kolei kilka biliotek doinstalowac aż będzie wszystko co trzeba...

        Zresztą tam w jakimś readme do tego launchera powinno byc napisane co trzeba doinstalować - warto tam zajrzeć.

      2. w terminalu , Blum 1/02/15 18:47
        dałem tak:

        sudo apt-get install libsdl2-2.0-0:i386 libsdl2-image-2.0-0:i386 libcurl3-gnutls:i386

        Potem coś po odpaleniu zaczynało się dziać, jednak crash i taki ogromny raport:

        https://www.dropbox.com/...2017%3A44%3A13.txt?dl=0

        1. hmmm , Strik 1/02/15 19:06
          Zainstaluj jeszcze libtxc-dxtn-s2tc0

          1. niestety i to nie pomaga , Blum 1/02/15 19:19
            znów gigant raport błędów...

            1. hmmm , Strik 1/02/15 19:23
              Na samym dole było info, że nie ma wsparcia do rozszerzenia.
              Szklana kula niestety nic mi nie podpowiada.

        2. hmmm a ten witcher to jest aplikacja 64bit czy 32? , ptoki 1/02/15 19:21
          bo doinstalowales 32bitowe biblioteki a system masz 64bit.
          Jesli witcher jest 32 bitowy to ok.
          Jak 64 bit to nie bardzo będzie gadać...

        3. masz gdzies linka do wymagan jakie ta gra ma? , ptoki 1/02/15 19:22
          bo narazie to troche w ciemno diagnozujemy...

          1. nie mam takiego , Blum 1/02/15 19:27
            może za słabego kompa mam?

            Sporo przejrzałem for z opisami problemu, ale mi tam wskazane kroki nie pomagają...

            1. Chiba jednak tak. , ptoki 1/02/15 21:50
              Wyszperałem to:
              http://en.cdprojektred.com/...nts-linux-witcher-2/

              Czy to dobra wersja gry?
              Jesli tak to integry intela są nie wspierane...

              1. to to akurat , krogulec 1/02/15 23:46
                wiele nie mowi. Wedlug tej stronki radeony tez sa niewspierane, a ja nie mam problemow z graniem na radeonie pod linuksem w wiedzmina 2. Za to na nvidii 840m nie chce mi sie teraz odpalic, chociaz wczesniej dzialal.

  2. eee... , daver 1/02/15 19:54
    Sorry, że nie nie pomagam w rozwiązaniu problemu - nie czytałem logów.
    Czy ja dobrze pacze? Ty chcesz odpalić to na integrze z biednego Pentium na Sandy Bridge? Jeśli dobrze pamiętam, to jakość tego portu (jeśli nie mylę z innym tytułem, to chyba nawet nie był port, tylko jakiś wrapper) była fatalna i to ledwo łaziło na mocnych sprzętach.
    Zerknij na phoronixa, wydaje mi się, że coś Michael pisał w ostatnich dniach o poprawionej becie, czy czymś takim.

    I use arch btw

    1. to laptop Lenovo B580 , Blum 1/02/15 20:45
      Więc na pewno nic specjalnego...

      1. hmm , krogulec 1/02/15 21:25
        juz chcialem napisac, zebys sobie odpuscil, bo na tej integrze intela w dodatku pod Linuksem moim zdaniem nie da sie grac, ale wedlug tego watku jednak sie da

        http://steamcommunity.com/...99444595483/?l=polish

        Z drugiej strony patrzac chocby po tym filmiku , ktory byl chyba nagrywany pod windowsem, to jednak ta gra jest srednio grywalna na tej grafice

        https://www.youtube.com/watch?v=0TdVzWzh19k

        1. to nie jest "ta" grafika , daver 1/02/15 21:54
          W w/w wątkach mowa o przynajmniej Ivy Bridge 4000 w parze z przynajmniej czterowątkowym i3. A tu jest najbiedniejszy, nisko taktowany SB Pentium z HD Graphics @650MHz. Grania, imho, na tym nie będzie.

          I use arch btw

    
All rights reserved ® Copyright and Design 2001-2019, TwojePC.PL