Twoje PC  
Zarejestruj się na Twoje PC
TwojePC.pl | PC | Komputery, nowe technologie, recenzje, testy
B O A R D
   » Board
 » Zadaj pytanie
 » Archiwum
 » Szukaj
 » Stylizacja

 
M E N U
  0
 » Nowości
0
 » Archiwum
0
 » Recenzje / Testy
0
 » Board
0
 » Rejestracja
0
0
 
Szukaj @ TwojePC
 

w Newsach i na Boardzie
 
OBECNI NA TPC
 
 » steve 06:57
 » NimnuL 06:56
 » PCCPU 06:54
 » Glock19 06:49
 » luckyluc 06:48
 » rulezDC 06:41
 » blimek 06:40
 » smichal 06:36
 » Mateusz00 06:22
 » cVas 06:18
 » P@blo 06:10
 » J@rek 06:10
 » Demo 05:57
 » hokr 05:57
 » piwo1 05:54
 » rad 05:48
 » RusH 05:44
 » charczenk 05:23
 » piszczyk 04:31
 » Kalkin 03:49

 Dzisiaj przeczytano
 13540 postów,
 wczoraj 47336

 Szybkie ładowanie
 jest:
wyłączone.

 
TwojePC.pl © 2001 - 2020
A R C H I W A L N A   W I A D O M O Ś Ć
    

Mint - problem z aktualizacją , Blum 4/02/18 12:49
Witam. Mam problem z aktualizacją minta. Przy jej próbie wyskakuje taki komunikat.


Wystąpił błąd

The following details are provided:

E: /var/cache/apt/archives/libdrm-common_2.4.89+git1801311830.9e34ad~oibaf~x_all.deb: próba nadpisania "/usr/share/libdrm/amdgpu.ids", który istnieje także w pakiecie libdrm-amdgpu1:i386 2.4.89+git1801190630.3509e7~oibaf~x .

Co robić?

  1. wyjebać , Killer 4/02/18 15:40
    zainstalować windows 7

    dziękuję :)

    Krew jego dawne bohatery
    A wzrost jego metr czterdzieści i cztery

    1. gówno wiedział ... , Seba 4/02/18 16:06
      ... to powiedział :)

    2. czy w przypadków problemów z Windows 7 , Master/Pentium 4/02/18 20:11
      zaproponujesz wyjebanie i zainstalowanie Mint'a? ;)

      Nie ma tego złego , co by się w gorsze
      obrócić nie mogło - jak nie wierzysz
      włącz komputer :-)

    3. prędzej by mi ręka uschła , Blum 4/02/18 21:29
      niż bym windę zainstalował

  2. a podaj więcej info. , Ranx 4/02/18 15:47
    To jest tylko mały fragment informacji z ekranu wg mnie
    dist-upgrade czy release?

    o roztramtajdany charkopryszczańcu...

    1. tutaj dłuższy komunikat którym dysponuję , Blum 4/02/18 21:32
      Rozpakowywanie szablonów dla pakietów: 100%
      Prekonfiguracja pakietów ...
      (Odczytywanie bazy danych ... 272704 pliki i katalogi obecnie zainstalowane.)
      Przygotowywanie do rozpakowania pakietu .../libdrm-common_2.4.89+git1801311830.9e34ad~oibaf~x_all.deb ...
      Rozpakowywanie pakietu libdrm-common (2.4.89+git1801311830.9e34ad~oibaf~x) ...
      dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/libdrm-common_2.4.89+git1801311830.9e34ad~oibaf~x_all.deb (--unpack):
      próba nadpisania "/usr/share/libdrm/amdgpu.ids", który istnieje także w pakiecie libdrm-amdgpu1:i386 2.4.89+git1801190630.3509e7~oibaf~x
      Wystąpiły błędy podczas przetwarzania:
      /var/cache/apt/archives/libdrm-common_2.4.89+git1801311830.9e34ad~oibaf~x_all.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      Nie udało się zainstalować pakietu. Próba powrócenia do poprzedniego stanu:

    2. i tutaj jeszcze to: , Blum 4/02/18 21:34
      sudo apt-get upgrade
      [sudo] hasło użytkownika sim:
      Czytanie list pakietów... Gotowe
      Budowanie drzewa zależności
      Odczyt informacji o stanie... Gotowe
      Obliczanie aktualizacji... Gotowe
      Następujący pakiet został zainstalowany automatycznie i nie jest już więcej wymagany:
      ocl-icd-libopencl1:i386
      Aby go usunąć należy użyć "sudo apt autoremove".
      Następujące pakiety zostały zatrzymane:
      libdrm-amdgpu1 libdrm-amdgpu1:i386 libdrm2 libdrm2:i386 libegl1-mesa libgbm1
      libgl1-mesa-dri:i386 libgl1-mesa-dri libwayland-egl1-mesa libxatracker2
      xserver-xorg-video-amdgpu
      Następujące pakiety zostaną zaktualizowane:
      clamav clamav-base clamav-freshclam firefox firefox-locale-en firefox-locale-pl fwupdate
      libclamav7 libcurl3 libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386
      libdrm-radeon1 libdrm-radeon1:i386 libegl1-mesa-drivers libfwup0 libgcab-1.0-0 libgl1-mesa-glx
      libgl1-mesa-glx:i386 libglapi-mesa:i386 libglapi-mesa libgles1-mesa libgles2-mesa
      libjavascriptcoregtk-4.0-18 libmysqlclient20 libosmesa6 libosmesa6:i386 libruby2.3
      libwebkit2gtk-4.0-37 linux-firmware linux-libc-dev mysql-client-core-5.7 mysql-common
      mysql-server-core-5.7 ndiswrapper ndiswrapper-dkms ndiswrapper-utils-1.9 openssh-client rsync
      ruby2.3 signal-desktop skypeforlinux ssh-askpass-gnome thunderbird thunderbird-gnome-support
      thunderbird-locale-en thunderbird-locale-en-us thunderbird-locale-pl xserver-xorg-video-ati
      xserver-xorg-video-intel xserver-xorg-video-radeon
      52 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 11 nieaktualizowanych.
      E: Nie udało się uzyskać blokady /var/cache/apt/archives/lock - open (11: Zasoby chwilowo niedostępne)
      E: Nie udało się zablokować katalogu /var/cache/apt/archives/

  3. masz konflikt pakietów. , ptoki 4/02/18 15:52
    Doinstalowales cos co chce nadpisac jedna biblioteke innym rodzajem tej biblioteki.

    Zanim nie dowiemy sie co dokładasz do systemu trudno będzie powiedzieć jak to najsensowniej naprawic. Szczególnie ze minta to wiele osób nie uzywa.

  4. Tu masz kilka , krogulec 4/02/18 19:38
    Możliwych rozwiazan:
    https://forums.linuxmint.com/...topic.php?t=253257

    Ja bym akurat na chama zdeinstalowal te pakiety przed aktualizacja (ale bez usuwania zależnosci) , zrobil aktualizacje i bez restartu (bo X-y moga nie wstac) zainstalowal je ponownie. Pakiety pochodzą zresztą pewnie spoza dystrybucji i pewnie to repozytorium z którego pochodzą też trzeba zaktualizować (zmienic wpis o nim). Pewnie to nie najlepsza metoda, ale u mnie zazwyczaj się sprawdzała (i w sumie nie ma znaczenia czy to mint , debian, ubuntu, centos czy arch, bo jak się instaluje pakiety spoza oficjalnego repozytorium, to tego rodzaju błędy czasami się niestety zdarzają)

    1. ta metoda nieco pomogła , Blum 4/02/18 22:11
      sudo add-apt-repository ppa:oibaf/graphics-drivers

      sudo apt-get update

      Zaktualizowała wszystko inne oprócz tego łajna libdrm. Ono cały czas nie daje się zaktualizować i pluje takimi komunikatami:

      E: /var/cache/apt/archives/libdrm-common_2.4.89+git1801311830.9e34ad~oibaf~x_all.deb: próba nadpisania "/usr/share/libdrm/amdgpu.ids", który istnieje także w pakiecie libdrm-amdgpu1:amd64 2.4.89+git1801190630.3509e7~oibaf~x

      (Odczytywanie bazy danych ... 272689 plików i katalogów obecnie zainstalowanych.)
      Przygotowywanie do rozpakowania pakietu .../libdrm-common_2.4.89+git1801311830.9e34ad~oibaf~x_all.deb ...
      Rozpakowywanie pakietu libdrm-common (2.4.89+git1801311830.9e34ad~oibaf~x) ...
      dpkg: błąd przetwarzania archiwum /var/cache/apt/archives/libdrm-common_2.4.89+git1801311830.9e34ad~oibaf~x_all.deb (--unpack):
      próba nadpisania "/usr/share/libdrm/amdgpu.ids", który istnieje także w pakiecie libdrm-amdgpu1:amd64 2.4.89+git1801190630.3509e7~oibaf~x
      Wystąpiły błędy podczas przetwarzania:
      /var/cache/apt/archives/libdrm-common_2.4.89+git1801311830.9e34ad~oibaf~x_all.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      Nie udało się zainstalować pakietu. Próba powrócenia do poprzedniego stanu:

    2. próba wywalenie pakietu kończy się tak: , Blum 4/02/18 22:59
      sim@sim ~ $ sudo apt-get remove libdrm-amdgpu1:amd64
      [sudo] hasło użytkownika sim:
      Czytanie list pakietów... Gotowe
      Budowanie drzewa zależności
      Odczyt informacji o stanie... Gotowe
      Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
      że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
      w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
      z katalogu Incoming ("Przychodzące").
      Następujące informacje mogą pomóc rozwiązać sytuację:

      Następujące pakiety mają niespełnione zależności:
      libgrantlee-textdocument5 : Wymaga: libqt5gui5 (>= 5.0.2) ale nie zostanie zainstalowany lub
      libqt5gui5-gles (>= 5.0.2) ale nie zostanie zainstalowany
      libkf5contacts5 : Wymaga: libqt5gui5 (>= 5.0.2) ale nie zostanie zainstalowany lub
      libqt5gui5-gles (>= 5.0.2) ale nie zostanie zainstalowany
      libqmenumodel0 : Wymaga: libqt5gui5 (>= 5.0.2) ale nie zostanie zainstalowany lub
      libqt5gui5-gles (>= 5.0.2) ale nie zostanie zainstalowany
      libqt5x11extras5 : Wymaga: libqt5gui5 (>= 5.0.2) ale nie zostanie zainstalowany lub
      libqt5gui5-gles (>= 5.0.2) ale nie zostanie zainstalowany
      E: Błąd, pkgProblemResolver::Resolve zwrócił błąd, może to być spowodowane zatrzymanymi pakietami.

  5. taka komenda pomogła , Blum 8/02/18 07:23
    sudo dpkg -i --force-all /var/cache/apt/archives/libdrm-common_2.4.89+git1802070630.bde3b9~oibaf~x_all.deb

    
All rights reserved ® Copyright and Design 2001-2020, TwojePC.PL